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1 Introduction 

This document is a simplified user's guide to the QGIS software, covering the basic 

functionalities of the software that are useful for Action Contre la Faim's missions. It 

begins with a brief description of some mapping concepts and geographic information 

systems GIS. 

The version of QGIS used is v3.22 "Białowieża". It can be downloaded directly from: 

https://qgis.org/en/site/forusers/download.html. However, it may have stability 

problems, in which case it is advisable to use the more stable v3.16 version. Most of 

the basic functions are identical between the two versions. 

The layers (Shapefiles and Rasters) used to illustrate this guide are open-source layers, 

i.e., free of right. The procedures for downloading data will be detailed in the text each 

time a new layer is used. 

A complete manual for using QGIS software is available on the net: 

https://docs.qgis.org/3.22/en/docs/index.html. It is a good complement to the topics 

covered in this short manual.  

Remarks:  

• Earlier and later versions of QGIS remain valid and you can continue to use them 

if you wish. Most of the basic functionalities are the same and this guide can also 

help you in their use. 

• All the sections framed in green correspond to a succession of exercises that can 

be completed as progressive training.  

 

https://qgis.org/en/site/forusers/download.html
https://docs.qgis.org/3.22/en/docs/index.html
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2 Introduction to some basic mapping concepts 

This chapter briefly explains what mapping is, with theoretical principles and practices. 

It also mentions the concept of Geographic Information Systems GIS.  

For this introduction, the QGIS software does not need to be open, just read to 

familiarise yourself with the concepts. 

2.1 Mapping theory 

Cartography is the making and study of maps. It has been an integral part of human 

history for a long time, perhaps more than 10 000 years. From cave paintings to the 

ancient maps of Babylon, from Greece to Asia, from the age of exploration to the  

XXI century, humanity has created and used maps as essential tools to help define, 

explain and navigate its way around the world.  

The map is a document that represents the features of a geographical area, extensive, 

in a miniaturised version, respecting distances, shapes and elevations (reliefs), showing 

roads, waterways, places of habitation... This representation of geographical space is 

based on scientifically established and accepted conventions. 

Maps are based on cartographic concepts presented below: 

The shape of the earth - geodesy 

The earth is not a perfect sphere, it is defined by a geoid which is an equipotential 

surface of gravity, an irregular surface defined by all the points where gravity is 

perpendicular and equal to the one at the level of the oceans. In general, the ellipsoid 

is used as a reference model to approximate the geoid. It is possible to make a local 

adjustment of the ellipsoid with a geodetic datum.  

Coordinate systems 

A coordinate system is a reference system that uses mathematical rules to specify 

positions (locations) on the earth's surface.  

The coordinate values can be spherical (latitude and longitude) or cartesian (distances 

X and Y from a reference point in a defined referential). 

A coordinate system is normally defined by a geodetic reference system, ellipsoid and 

projection and the units are in degrees or metres. 
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Types of coordinate systems 

➢ Geographic coordinate system: 

The use of latitude and longitude to position points on a mathematically simple 

reference surface that best represents the shape of the Earth. 

• Longitude (in degrees) is a spherical coordinate whose origin is the Greenwich 

meridian and is conventionally noted as positive towards the East, and negative 

towards the West. 

• Latitude (in degrees) is a spherical coordinate whose origin is the equator and by 

convention is positive towards the North and negative towards the South. 

• Geographical coordinates are often expressed in decimal degrees (DD) 

Decimal degrees are similar to degrees, minutes, seconds (DMS), but minutes 

and seconds are expressed as decimal values. Decimal values make storage and 

computation easier and faster. 

 

➢ Projected coordinate system: 

A graphic image of the world on a plane, such as the Universal Transverse Mercator 

(UTM) projection. The UTM system is the most widely used in cartography. UTM 

divides the earth into 60 numbered vertical zones that are 6 degrees in longitudinal 

width. Burkina Faso lies between zones 30N and 31N, Niger between 31N, 32N and 

33N, Senegal 28N, Mauritania 28N and 29N; and Mali 29N, 30N, 31N. 

Coordinates of a point are given by the distance X (towards the North) and Y (towards 

the East), expressed in meters on the earth surface, from the lower-left corner of the 

UTM zone. 

 

 

 

 

 

 

 

 

Figure 1 – UTM zones 



QGIS SOFTWARE USER GUIDE V1                                                                                  7 

ACTION CONTRE LA FAIM | ACTION AGAINST HUNGER | Regional Office for West and Central Africa 

www.actionagainsthunger.org | www.actioncontrelafaim.org | www.accioncontraelhambre.org 
www.sigsahel.info 

Map projection  

It is necessary to project maps to move from the globe to the plane. There is a multitude 

of projections respecting four main properties: 

• Conformity: conservation of angles around a 

point 

• Equivalent: conservation of surface proportions 

• Equidistance: conservation of distances 

• True direction: conservation of directions 

No projection satisfies all four properties, and it is, 

therefore, necessary to make compromises. 

It is necessary to use an adapted projection before 

calculating distances or superficies. 

The Notion of Scale 

As stated in the definition of the map, it is a miniaturised representation of reality that 

tries to respect real distances. This miniaturisation is achieved using a scale. 

A map scale is the relation between a distance on the map and the actual distance on 

the ground. 

There are different types of scales: 

Verbal Scale: "one cm on the map is ten km in the field". 

Digital scale: 1:10 000 

Graphical scale:  

Scale of an area:  

 

➢ Small and large scales concept 

 

A small scale represents a large portion of the earth's surface. It allows the 

representation of large areas. Examples: World map, Map of West African countries, 

Map of Senegal. (Scale: 1:250 000).  

A large-scale map represents a small portion of the geographical space. It provides more 

detail than a small-scale map. For example, a map of a house, a field of crops, a map of 

a neighbourhood in Dakar (Scale: 1:5 000). 

Represents 1 km2 
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Calculating the scale of a map: 

For example, if 2 cm on the map represents 1 km on the ground the scale is  

2 cm = 1 km, or... 

Distance on the map

Distance in the field
= 

2 cm

1 km
= 

2 cm

100 000 cm
=

1

50 000
 

   Scale: (1:50 000) 

NB: Scales do not have a unit (ratio). 

2.2 Geographic Information Systems GIS 

2.2.1 GIS definitions 

GIS is an acronym used for Geographic Information Systems. Many definitions of GIS 

have been proposed in academic and institutional literature. Among the most widely 

used are the following: 

According to Marble (1983), a GIS is “A system for collecting spatial data”.  

Clarkes (1986) defined it as “a computer-aided system for capturing, storing, retrieving, 

analysing and displaying spatial data in a particular organisation”. 

For Burrough (1987), it is “A powerful spatial tool for collecting, storing, retrieving, 

transforming and displaying real-world data”.  

Parker (1988) sees it as “an information technology that stores, analyses and displays 

spatial and non-spatial data”.  

For Arnoff (1989), “A computer system that provides four sets of capabilities for 

managing geo-referenced data: data input; data management; data manipulation and 

analysis; and data output”. 

According to the US Federal Interagency Coordinating Committee on Digital Mapping 

(FICCDC, 1988), a GIS is “a computer system of hardware, software, and processes 

designed to enable the collection, management, manipulation, analysis, modelling, and 

display of spatially referenced data to solve complex planning and management 

problems”. 
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Taking these different definitions into account will allow you to design your own 

definition of GIS. For this, you will not need many words but only six letters of the 

alphabet: C, S, R, T, A, V. 

C: Collect/record 

S: Store 

R: Recover 

T: Transform  

A: Analyse 

V: Visualising data (spatial and attributes) 

2.2.2 The components of a GIS 

According to ESRI (www.esrifrance.fr/societe/sig2.htm), a Geographic Information 

System consists of 5 major components: hardware, software, data, methods and users. 

 

 

 

 

 

 

 

 

Figure 2 – Geographic Information System scheme 

 

• Hardware is used to capture data (keyboard, scanner...), display information 

(screen) or store data (hard disk). 

• Software is used to perform analysis, extraction and management of data. 

• Data is at the heart of the system. All analyses are based on collected and 

stored data. This collection is done using GPS, scanners, digitisers, existing 

spreadsheets, or collected from other sources (satellites). 

• Methods or procedures are designed by GIS specialists to specify the type of 

analysis the system should perform. 

• Users refer to GIS specialists and various customers for GIS products. 
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2.2.3 Uses and users of GIS 

What can be achieved with a GIS?  

➢ A GIS system allows the visualisation and analysis of geospatially referenced 

data. 

Who benefits from GIS?  

➢ Anyone who requires analysis of a geographical area. GIS helps in decision 

making. 

Despite the highly advanced features inherent in a GIS, few users push the system to 

its limits. Some of the applications of GIS, from the simple to the more complex, are 

listed below. 

Single level 

• Consultation of data to provide answers to questions such as: Does a certain 

place exist? Where can we find such and such objects? What is the extent of a 

phenomenon? Data management and updates: Management of objects and their 

attributes: changes, additions, deletions, assembly, copy/paste.  

• Data creation - Done by importing data or digitising. 

• Production of simple map outputs 

Intermediate level  

• Data overlay about map production. This includes Data interpretation for simple 

statistical analysis and thematic analyses; Data interrogation using selection, 

queries and structured queries (SQL). 

• Production of elaborate map outputs 

Advanced level  

• Spatial analysis: Spatial interpolation and advanced statistical analysis based on 

existing information from neighbouring objects, can detail of missing information 

be derived from the process?  

• Spatial modelling: Mathematical (simplified, schematic) reconstruction of an 

actual geographical space; Geographical simulations of space for behavioural 

testing; Modelling can be two-dimensional (to visualise the magnitude of a 

parameter or spatial feature), but most often such a model is multi-dimensional 

including a dimension can be spatial (altitude, height or depth), temporal 

(changes based on a time sequence for a particular area), or any other parameter 

(to demonstrate the impact of the parameter). 
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What are the main areas of application of GIS? 

➢ Geographical representation:  

• Thematic mapping: To produce maps for different themes and areas.  

➢ Geographical management:  

• Rural and urban environments. To integrate the study and development of a 

space or a landscape. 

➢ Inventory and management of natural features: 

• Water management. Irrigation and drainage systems provide water quality 

control and water management works. 

• Forest management.  

• Management of natural parks.  

• Inventory and management of national monuments and archaeological sites.  

• Inventory and management of natural resources. 

• Inventory and mapping of soil and geological conditions.  

➢ Environment:  

• Impact studies and development of phenomena (desertification ...).  

• Forecasting risks of natural origin and preventing disasters.  

➢ Precision agriculture:  

• Crop management, production estimates and fertiliser dosages.  

➢ Geo-Marketing:  

• Management of sales, stocks, transport logistics.  

➢ Statistics:  

• Demographic studies. 

What are the GIS user categories? 

➢ Occasional users:  

This type of user mainly uses GIS in reading mode. They review and consult GIS data 

and maps on the Internet for day-to-day use. They rarely realise that they are using a 

GIS system.  

➢ Basic users:  

This category consists mainly of GIS operators and technicians. They have limited 

knowledge of the GIS tool which they use routinely, a well-defined task such as map 

digitisation and the association of related attributes. They generally have a good 

knowledge of some operations and are less aware of some other elements of the 

system. 
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➢ Intermediate users:  

These users can use GIS to solve a theoretical problem. They are capable of planning 

and implementation operations such as data extraction, queries and interpolation.  

➢ Advanced users:  

These types of users can design a strategy for the implementation of a GIS. They can 

ensure the smooth running of a project and are defined as project managers. Their in-

depth knowledge of GIS principles, concepts and functions enable them to effectively 

use the structure, usability and methods to meet project objectives. 

2.2.4 Concept of geographic data 

Data is at the heart of any GIS analysis. For this reason, Phil Parent (1988) defined GIS 

as "a system that contains spatially referenced data that can be analysed and converted 

into information for specific purposes. The main feature of a GIS is the analysis of data 

to produce new information". 

Based on this definition, a distinction must be made between geographic data and other 

types of data. Geographic data refers to any data about entities located spatially on the 

face of the Earth using the coordinates of its location. This dataset can be, for example, 

drinking water points, roads, railways, parcels of land use types, or political and 

administrative boundaries. 

There are two models for representing geographic data: vector model and raster model.  

Vector model corresponds to a geolocated shape which can be a point, a line or a 

polygon with an array of associated attributes. 

Raster model includes satellite images, aerial photos, digital elevation models (DEMs) 

and often scanned or digitised entries from paper map documents. 
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Figure 3 – Examples of vector and raster data 

 

1. Vector data 

A GIS represents vector data on a map using points, lines or polygons.  

Points are used as an abstraction for water points (wells, boreholes, public taps), 

schools, health centres (CSI, CS hospitals), towns (depending on the scale of the map). 

Lines are used to represent waterways (river systems, aqueducts, stormwater drainage), 

city streets, road types and networks (telephone lines, water pipes, bus lines…). 

Polygons represent areas and their boundaries (agricultural land, water bodies, regions, 

countries, continents). 

In vector mode, each entity is linked to an array of data containing information about 

it. These are its attributes. For example, a point feature representing traditional wells 

in a community will have an array linked to it presenting the characteristics of each well 

for instance depth, water flow, water use, and whether the water is permanent or not. 

In the case of polygon features such as a state in the USA, the attribute table can 

contain various information such as the total population of the state, the population for 

different census years, and the number of households. In short, all the data collected 

on that state can be linked to the polygon that represents the state for map analysis. 

Examples of 

vector data 

Examples of 

raster data 

Villages 

Administrative 
boundaries 

Road network 

Refugee’s 
camps 

Hydrography 

Vegetation 

Topography 
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Figure 4 – Example of a polygon with its attribute table (US Map) 

Principal advantages of vector data 

• More accurate representation of the location of geographical objects 

• Ability to store many attributes 

• Flexibility for mapping 

• Suitable for certain types of analysis, such as area, length and network analysis 

Principal disadvantages of vector data 

• Vector data could become heavy to handle 

• Vector data is not adapted to every kind of information: satellite imageries, 

meteorological model outputs… 

 

2. Raster data 

 

The raster model corresponds to a mesh or grid of regular cells (pixel). Unlike the vector 

model, each grid cell is represented by a single attribute value. 

The raster model can be used to represent point, line and area features like the vector 

data model. However, the raster data model lacks precision when representing these 

graphical features. In the graph on the right, the grid cells in green with '3' as the value 

number represent a polygon feature. The black cell with a label '1' represents a point 

feature, while the red squares marked with '2' represent a line feature. 
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Figure 5 – Examples of raster representation 

Principal advantages of raster data 

• They are the best way to store continuous values such as elevation or distance; 

• Raster analysis is faster and more flexible than vectors for many applications (e.g. 

hydrological modelling); 

• Some analyses are only possible with raster data analysis (Catchment 

delineation); 

• The raster allows the visualisation of large geographical areas (satellite images). 

Principal disadvantages of raster data 

Raster data has some disadvantages compared to vector data, among these: 

• The boundaries of the entities are blurred (see figure below) 

• Lack of precision in the representation of features 
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3 Introduction to QGIS 

QGIS is a free and open-source Geographic Information System software developed by 

volunteers and is constantly evolving. It aims to be an easy-to-use GIS software, 

providing common features. QGIS is distributed under the GNU GPL license, which 

allows the source code to be openly studied and modified. QGIS allowing to: 

• Visualise data (including vector and raster data) 

• Create, edit, manage and export data 

• Analyse data 

• Create maps 

The best tools to learn the software are curiosity and patience. Never hesitate to look 

for answers to your questions on the internet, the QGIS user’s community is huge and 

prolific. 

3.1 Downloading and Installing QGIS 

To download QGIS, you need to have an internet connection and go to: 

https://qgis.org/en/site/forusers/download.html. Depending on the characteristics of 

the computer on which the software is to be installed, it is advisable to download the 

32 or 64-bit version of the latest version of QGIS. As already mentioned in the 

introduction, this version may not be stable on some older computers. In this case, it is 

certainly possible to use the older version QGIS 3.16 which can be downloaded from 

the same site. However, this version will not offer all the functionality of a newer 

version. 

Once QGIS is installed, go to the start tab on your computer and type QGIS in the 

search bar. There are several options, select QGIS3.xx Application and click on it. The 

program will open and the first time you use it, it will give you two options, choose 

“Clean start”. 

Once launched, QGIS will present you with an interface like other GIS software 

 

 

 

 

https://qgis.org/en/site/forusers/download.html
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3.2 QGIS main interface 

When QGIS starts, the interface looks like the figure below. The interface can be 

divided into 6 main areas, numbered 1 to 6 in Figure 6, which are:  

  

 

 

 

 

 

 

 

 

Figure 6 – QGIS interface 

 

1. The menu bar gives access to different QGIS features. 

2. The toolbar provides access to most menu functions. Each toolbar can be moved 

as required and each tool has a tooltip that is displayed when we place our cursor 

over it. 

3. The panels are provided by default by QGIS. There are two panels: a table of 

contents showing the layers displayed on the map and the directory showing the 

location of the layers on the computer. 

4. The central part of QGIS where maps are displayed. 

5. The status bar provides generic information about the map and the map view: 

the coordinates of the represented space, the map scale, the projection system. 

6. The Browser allows you to navigate through the computer's folders and data 

services. 

It is possible to manage the type and number of panels and toolbars to be displayed. To 

do this, go to the "View" menu and click on Panels or Toolbars. 

 

1 

2 

6 

4 

3 

5 
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3.3 Create a project, save it, close it and open it 
 

QGIS works with projects. QGIS cannot work on several projects at the same time. It is 

necessary to save your project using the Project > Save project as... 

 

To load a project previously saved in a QGIS session, go to Project > Open 

 

If you want to open a blank session, go to Project > New  

 

Activity: Open a new project 

Before you start working, you are asked to create a project, give it a name,  

e.g., ACF_Training_GIS.qgz and save it in an appropriate folder. 

 

A project will then reference layers by their path. If a layer used in a project is moved, 

renamed or deleted, the project will not be able to find it anymore. Therefore, it is 

advisable to create a folder with the project inside and all the layers that refer to it. 

 

3.4 General QGIS tools 
 

QGIS has tools for zooming and moving to an area of interest. The button         allows 

you to move around the map and the buttons           and        are used to zoom in and 

out on the map.   

   

Zoom in on the map with the mouse wheel. It is necessary to place the cursor in 

the display area of the map and if you roll the wheel forward, it will zoom in. Move 

around the map with the arrows and the space bar or simply by holding down the mouse 

wheel. 

The Measure tool            allows you to measure distance, area and angles. The tool     

allows you to obtain information on an element of a layer, either an entity of a vector 

layer or a pixel of a raster layer. To obtain the information of the desired layer, it is 

necessary to select the layer in the panel area by simply clicking on it.  
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3.5 Adding raster or vector layers to a project 

In QGIS, it is easy to add raster and vector layers. Different layers are available in the 

training dataset, in the folder Data/: 

A raster layer Data/GeoSahel/BiomassAnomaly2021.tif corresponding to the biomass 

production anomaly map for season 2021 over the west and central Africa. This layer 

is produced by the ACF Pastoral Early Warning System and can be downloaded directly 

from the GeoSahel website at this link: 

http://geosahel.info/Viewer.aspx?map=Analyse-Biomasse-Finale 

Administrative vector layers over the west and central Africa produced by the  United 

Nations Office for the Coordination of Humanitarian Affairs (OCHA): 

wca_admin0_ocha.shp, wca_admin1_ocha.shp, wca_admin2_ocha.shp and the cities of 

the west and central Africa: wca_pplp_ocha.shp The shapefiles can be downloaded 

directly from the Humanitarian Data Exchange (HDX) website: 

https://data.humdata.org/dataset/west-and-central-africa-administrative-boundaries-

levels 

To add the shapefile layer, click on menu Layer > Add layer > Add vector layer         , 

and then browse the selected folder and choose the file with extension .shp standing 

for shapefile. 

To add the raster layer: Anomalie_biomasse_2021.tif click on the icon Layer > Add layer 

> Add a Raster layer         , and then browse the selected folder and choose the file with 

an extension .tif standing for GeoTIFF. 

 

 

To add a layer, it is possible to drag it from its folder by sliding from the Browser 

panel to the Layers panel. Be careful to correctly insert .shp or .tif files. 

 

Several simple manipulations can be done on the layers. For example: 

• To centre the map on a layer, right-click on the layer > Zoom to Layer(s) 

• To duplicate a layer, right-click on the layer > Duplicate Layer 

• To delete the layer, simply: right-click on the layer > Delete Layer 

On the QGIS interface, the order of display of the layers in the layer window 

corresponds to the order of appearance in the main window. Therefore, you will not be 

able to see the boundaries of the regions wca_admbnda_adm1_ocha if the country’s 

layer wca_admbnda_adm0_ocha is above. To reorder the layers, simply select them and 

move them. 

http://geosahel.info/Viewer.aspx?map=Analyse-Biomasse-Finale
https://data.humdata.org/dataset/west-and-central-africa-administrative-boundaries-levels
https://data.humdata.org/dataset/west-and-central-africa-administrative-boundaries-levels
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Activity: Add layers onto the project 

✓ Add the layers wca_admbnda_adm0_ocha.shp, wca_admbnda_adm1_ocha.shp, 

wca_admbnda_adm2_ocha.shp, wca_pplp_ocha.shp and BiomassAnomaly2021.tif 

to your project 

✓ Uncheck wca_admbnda_adm1_ocha, wca_admbnda_adm2_ocha, wca_pplp_ocha 

and BiomassAnomaly2021 

✓ Zoom in on the wca_admbnda_adm0_ocha.shp layer 

✓ Reorder the layers as shown in Figure 7 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 7 – Layers added to QGIS project 
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4 Vector data 

Vector data is generally used to make maps. How to add vector layers in the shapefile 

.shp format has already been discussed earlier. This section details how to process and 

display vector data. 

4.1 Properties of the layers 

Each layer, whether vector or raster, has a set of properties to explore. To display the 

properties of a layer: Right-click on the layer > Properties or double click on the layer. 

The properties of the layers are the following: Information, Symbology (Style, Labels, 

…), Fields, etc. Many actions can be performed from the layer properties, such as 

changing the display symbology or the labels. 

4.2 Attribute tables 

All vector layers have an attribute table that adds a data table to the spatial features. 

To access it: right-click on the layer > Open Attribute Table      . This opens a new 

window that displays the attributes of all features in the layer. Each row represents an 

entity with its attributes distributed in several columns. Each entity can be searched, 

moved and edited. The buttons at the top of the attribute table are used to call up 

features, the most useful of which are: 

•       Activate the editing mode and stop the editing mode when finished 

•       Save changes 

•       Add an entity 

•       Delete selected entities 

•       Selecting entities using an expression 

•       Select all 

•       Deselect all 

•       Move the selection to the top 

•       Zoom the map to the selected lines 

•       Delete a field 

•       Add a field 

•       Open the field calculator 
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Attribute values can be edited manually once the session is in edit mode       . It is then 

possible to double click on a box and change the value. It is also possible to add a new 

empty field and then fill the field values manually         .  

Activity: Add attribute information with the population of each country 

✓ Right-click on the wca_admbnda_adm0_ocha layer and open the attribute table 

✓ Activate an editing session in the attribute table, then add a field and name it 

“Population”, select the type Decimal number (as a real number) 

✓ Add manually the populations in millions of all countries concerned, namely:  

Benin 12.8, Burkina Faso 22.1, Cabo Verde 0.6, Cameroon 27.9,  

Central African Republic 5.0, Chad 17.4, Côte d’Ivoire 27.7,  

Democratic Republic of Congo 95.2, Equatorial Guinea 1.5, Gabon 2.3, Gambia 2.6, 

Ghana 32.4, Guinea 13.9, Guinea Bissau 2.1, Liberia 5.3, Mali 21.5, Mauritania 4.9, 

Niger 26.1, Nigeria 216.7, Republic of Congo 5.8,  

Sao Tome and Principe 0.2, Senegal 17.7, Sierra Leone 8.3, Togo 8.7 

✓ Save changes and exit edit mode 

The button Field Calculator         in the attribute table allows calculations to be made 

based on the attribute values, but also to use functions to, for example, calculate an 

area or length of an entity. The results can be stored in a new column of the attribute 

table or in a column that is updated. When the field calculator button is clicked, a 

window opens. If the layer is not in edit mode, a window opens to warn you to switch 

to edit mode.  This is because no changes can be made without having activated editing. 

The field calculator provides a comprehensive interface for creating expressions. It is 

very similar to the window for selecting attributes based on an expression. The 

applications of this tool are enormous and are not all detailed here. For more 

information, please refer to the full QGIS manual. 

Activity: Add attribute information with area in km2 for each country 

✓ Start an editing session by clicking on the pencil 

✓ Enter the field calculator and add a field, named ‘Area’ of Decimal number type 

✓ Calculate the area using formula $Area / 1000000 

✓ Save the changes and exit 
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Figure 8 – Attribute table of country layer 

4.3 Layer symbology - vector formatting 

4.3.1 Type of rendering 

It is often necessary to modify the displayed appearance of layers when making maps. 

To do this, right-click on the layer > Properties > Symbology        . It is necessary to 

choose the type of symbol we want to apply, the 4 most common types of symbols are: 

single symbol, categorized symbol, graduated symbol and the inverted polygon.  

•        The single symbol mode allows representing all the entities of a layer in the 

same way, e.g., country background in a single colour. 

 

•        The categorized rendering mode allows displaying the entities of a layer 

classified by category depending on the attribute table. The categorized 

rendering allows us to select the attribute (the field of the attribute table 

according to which we want to display), the symbol (ex: point, square, star, ...) 

and the colour. It is necessary to click on Classify to generate the classes for all 

the values of the attribute table. 
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•        The graduated mode allows the entities of a layer to be displayed with a 

colour palette according to the value of the attribute. It is also possible to specify 

the symbol, format, colour and size. It is also necessary to choose the number of 

classes and the classification method: 

o Equal intervals: all classes have the same size 

o Quantile: all classes have the same size 

o Natural breaks: maximum intra-class variance and maximum inter-class 

variance 

o Standard deviation: classes constructed based on the standard deviation 

 

•          Inverse Polygon mode allows you to apply a symbol to the outside of a 

layer. This is useful if you want to give a colour to the outside of your area of 

interest, for example. 

 

Activity: Display countries in different colours 

✓ Right-click on the layer wca_admbnda_adm0_ocha then go to properties, Symbology 

and choose Categorized rendering 

✓ As Value select the admin0Name field and click on classify 

✓ Change the colours one by one by double-clicking on the Symbol associated with each 

country 

✓ Click to ‘Apply’ and check that you are happy with the rendering 

 

Activity: Display the capital cities with a symbol 

✓ Right-click on the layer wca_pplp_ocha and go to Properties, Symbology and 

Categorized symbol 

✓ As Value select popPlace_1 and click on classify 

✓ Activate only the Symbol corresponding to the National capital by unchecking all the 

others 

✓ Double click on the symbol associated with the National capital and on the Symbol 

Selector window choose the symbol ‘topo pop capital’ and click ‘OK’ 

✓ Click ‘apply’ and ‘OK’ 

✓ Activate layer wca_pplp_ocha and check for the result 
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Figure 9 – West and Central Africa countries and capitals 

4.3.2 General rendering options 

It is also possible to apply rendering options to the entire layer, such as the transparency 

option, which makes the layers below visible.  

4.3.3 Types of symbols 

There is a multitude of symbols in QGIS. It is possible to modify the type of symbol, the 

thickness of the lines/edges of polygons, etc. All these tools are easily accessible, and 

we will not go into detail. Please refer to the online QGIS manual for further 

information. 

4.4 Adding labels  

It is useful when creating maps to display labels. For example, the names of countries 

or cities so that they are visible on the final map. This labelling menu can be used for 

polygons (e.g. countries), lines (e.g. roads) and points (e.g. cities). To do this, you need 

to right-click on the layer > Properties > Labels 
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The first step in displaying a label is to choose the labelling method from a drop-down 

list. Four options are available:  

• No label 

• Singles Labels: all entities of the layer get the same label format  

• Rule-based labelling: entities of the layer get different label formats (size, 

colour…) 

• Blocking: to prevent other labels from overlapping with the entities in the layer 

Next, check the Single Labels option for this layer and select the attribute field from 

which the labels should be taken. The following menus allow you to configure the 

labelling: 

• Text: to define the text style (font, size, colour) 

• Formatting: to define a line break 

• Buffer and mask: to create a buffer or a mask around the text to make it more 

visible 

• Background: to give a colour to the text background. The size of the coloured 

area can be set by Size X and Size Y 

• Shadow: to have a shadow cast behind the text 

• Callouts: to add a line connecting the entity to the label 

• Placement: to select the location of the label. The location options vary 

according to the type of geometry: point, line and polygon 

• Rendering: to fine-tune the rendering of the labels, including important option 

to “Show all labels for this layer (including colliding labels)” 

It is also possible to define labels based on an expression, for example, to display the 

name of a country and below it the area. To do this, click on    and then enter an 

expression, following a few simple rules:  

• Combine all elements with a concatenation function like concat, + or || 

• Strings need to be written using ‘single quotes’ 

• The fields of the attribute table need to be written with ''double quotes'' 

 

Some examples: 

• Label based on two fields: country and population:  

    ''Admin0Name'' || ',' || ''Population'' || ' million' → Mali, 21.5 million 

• Label based on two fields with one line: 

 ''Admin0Name'' || '\n' || ''Population'' || ' million' →     Mali 

                 21.5 million  
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Activity: Display names of the countries 

✓ Right-click on the layer wca_admbnda_adm0_ocha > Properties > Labels 

✓ Select "Single Labels" and select the admin0Name field as Value 

✓ Change the size, font and colour and buffer as you wish 

✓ Then try to reproduce the examples shown above with the name of the country and 

the population number 

 

 

 

 

 

 

 

 

 

 

 

Figure 10 – West and Central African countries population 

 

4.5 Synthesis exercise 

To summarise what you have learned about symbology and labels; you are asked to 

reproduce the map below with the following characteristics:  

✓ Display countries in grey in the background with a thick border 

✓ Display country names in uppercase with a buffer 

✓ Display region boundaries with a thinner border than countries 

✓ Choose a special symbol for capitals 

✓ Display city names in red with a buffer and a capital letter on the first letter only 
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Figure 11 – Symbology and labels exercise result 

 

4.6 Making data queries 

QGIS provides several tools for selecting features directly on the display. To select one 

or more features over a layer, it is necessary to click on the tools bar on “Select Features 

by area or single click”         and then choose the type of selections:  

•       Select entities with a rectangle or by clicking (default) 

•       Selecting entities with a polygon 

•       Freehand selection of entities 

•       Select entities by a radius 

•       Deselect all selected entities 

 

Activity: Extract one entity of countries layer 

✓ On the Layers panel, select layer wca_admbnda_adm0_ocha as it becomes 

highlighted 

✓ Activate the select features tool, then select the Niger by clicking on the display 

✓ Export the selected feature by right-clicking on layer checking 

wca_admbnda_adm0_ocha and Export > Save Selected Features as… 

✓ Choose format ESRI Shapefile, and File name Niger_adm0.shp 

✓ Zoom on the newly created layer automatically added to the project 
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The attribute table is linked to the vector layer. Therefore, if you select an entity in the 

layer using the select feature tool, this entity is also selected in the attribute table. In 

the same way, when you select a row in the attribute table, the corresponding entity is 

selected in the layer. To select multiple rows, simply hold down the ctrl key.  

It is also possible to select attributes using rules. In this tool, a list of functions allows 

you to select entities by an expression that is often based on Fields and Values that you 

must select. An example is shown in Figure 12 and you are asked to perform it. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 12 – Illustration of a rule-based selection of entities 

 

 

 

Activity: Selection of regions that belong to the country Mali 

✓ Open the attribute table of Layer wca_admbnda_adm1_ocha 

✓ Activate the tool “Select features using an expression"  

✓ In the list of functions, pull down the Fields and Values menu and choose 

admin0Name by double-clicking 

✓ Click on '='  

✓ Click on load all unique values and choose 'Mali' 

✓ The final expression should be ''Admin0'' = 'Mali' 
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4.7 Create a shapefile from a selection of features 

When a selection has been made, it is possible to export it to a new database and create 

a new shapefile. To do this: right-click on the layer containing the selected features > 

Export > Save Features as. A window opens, you need to indicate the name of the new 

dataset to be exported and check the "Save only selected features" option. 

4.8 Adding data based on a delimited text file 

It is common to have a text file (csv, txt, ...) containing point coordinates and to want to 

import it into QGIS to have a spatial representation. QGIS allows you to import a 

delimited text file as a vector layer if the text file meets the following 3 conditions: 

• The first row of the file contains the field names for each column 

• Some fields describe the geometry (coordinates) 

• The X and Y coordinates (i.e., longitude and latitude) must be in numerical format 

To add this kind of file as a new layer, you can use it in the Menu:  

Layer > Add Layer > Add Delimited Text Layer. The shows the window that opens. It is 

necessary to select the file to be imported and then to specify the delimiter, the X field 

being the longitude and the Y field being the latitude. You also need to define the 

geometry which is usually Point. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 13 – Window for adding a delimited text file 
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Activity: Open a text file coming from ACF pastoral surveillance system 

✓ In the training folder, find the file: 

Pastoral_Sentinel_Sites/relais_sentinelles_pastorale_Niger_avril-mai_2021.csv 

✓ Open the file with spreadsheet software like Excel to see what it looks like 

✓ In QGIS, Go to Menu > Layer > Add Delimited Text Layer and search for the file 

✓ Choose the windows-1252 as Encoding 

✓ Choose the column separator as the semicolon 

✓ Choose the comma as the decimal separator 

✓ Make sure that the X and Y fields are checked correctly so that they correspond to 

the latitude and longitude 

✓ Click on Add to import the file as a Layer 

✓ Observe the location of the sentinel sites to ensure that the import has been carried 

out correctly 

 

 

 

 

 

 

 

 

 

 

 

Figure 14 – ACF Pastoral Sentinels location over Niger 
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4.9 Extracting information and analysing data 

Many tools are available in QGIS for processing vector data. They will not be detailed 

here but documentation is available on the QGIS online documentation. To access the 

tools, go to the Menu Vector > Tools drop-down menu 

• Geoprocessing tools: buffer, union, dissolution, etc. 

• Geometry tools: centroid, triangulation, simplification, etc. 

• Analysis tools: statistics 

• Data management tools: database management 

• Search tools: selection by location or by attributes 

 

 

Activity: Create a buffer of 10 km around each sentinel site 

✓ Reproject the layer relais_sentinelles_pastorale_Niger_avril-mai_2021 to UTM 

projection: Menu Vector > Data Management Tools > Reproject Layer and select 

EPSG:32632 – WGS 84 / UTM zone 32N as Target CRS, and click Run 

A new temporary Layer called “Reprojected” is added to the Layers panel 

✓ Click on Vector > Geoprocessing Tools > Buffer, and use the layer “Reprojected” as 

Input Layer, set the distance to 10 km and click Run 

A new temporary Layer called “Buffered” is added to the Layers panel 

✓ Observe the result 

 

 

 

 

 

 

 

 

 

 



QGIS SOFTWARE USER GUIDE V1                                                                                  33 

ACTION CONTRE LA FAIM | ACTION AGAINST HUNGER | Regional Office for West and Central Africa 

www.actionagainsthunger.org | www.actioncontrelafaim.org | www.accioncontraelhambre.org 
www.sigsahel.info 

4.10   Filters 

The filter tool allows you to show only certain elements that interest you. To access 

this tool, right-click on the layer > Filter       .  A window opens with a list of fields from 

the attribute table on one side, the values of each field on the other and a space to 

write an expression. In this case, we will simply choose a value for one of the fields: 

''field_X'' = ''value_Y''. The layer will then show only the vector associated with the 

selected value. When a layer is filtered, the icon appears next to it. 

Activity: Apply a filter on a layer 

✓ Right-click on layer wca_admdnda_adm2_ocha and select “Filter” to open the filter 

Query Builder window (Figure 15) 

✓ Type a query to select only admin2 of Mali 

✓ Look at the effect on the map after activating the layer 

 

 

 

 

 

 

 

 

 

Figure 15 – Filter Query Builder window 
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Figure 16 – Administrative boundaries level 2 over Mali 

 

4.11    Joins 

4.11.1 Joining by attributes 

The joins tab allows you to join a vector layer to an attribute table (e.g., an Excel file). 

This can be very useful if you have for example a table with data of malnutrition 

organised by administrative region and you want to link it with the shapefile on 

administrative regions. To do this, simply right click on the layer > Properties > Join.  

Then click on the button       to add a vector to be joined. It is necessary to define the 

join layer to be connected to the target layer (the one on which you have opened the 

properties window). You are then asked to specify the name of the joining field which 

is the common field for both layers (the name of the administrative regions in the 

example above). By default, all the information in the table will be joined but it is 

possible to specify the fields to be joined so that not all the fields are added.  
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Activity: Add prevalence of Malnutrition on the attribute table 

✓ Open the file SMART/Niger_SMART_2016.xlsx with Excel and save it as a Comma-

separated values (.csv) file 

✓ In QGIS, add the .csv table by clicking on: 

Layer > Add Layer > Add Delimited Text Layer 

selecting the option: "No geometry (attribute table only)” 

It might be necessary to define the correct delimiter in File Format  

✓ Open the Joins window:  

Right-click on the layer wca_admbnda_adm1_ocha > Properties > Joins 

And click on  

✓ Perform the join of the added table using the field admin1Pcod in both “Join field” 

and “Target field” (Figure 17), click OK and then Apply 

✓ Verify the result by opening the attribute table 

 

 

 

 

 

 

 

 

 

Figure 17 – Add Vector Join window 
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4.11.2   Spatial connection 

The spatial join allows you to add information to a layer according to its spatial location. 

For example, it is useful to add to a point layer (e.g., schools), the administrative zones 

to which the entities belong. The tool is available in Vector > Data management tools > 

Join attributes by location.  

4.12    Coordinate conversion 

Each layer (shapefile or raster) is defined by a reference coordinate system (RCS). There 

are, as already stated above, two main types of RCS:  

• Geographic coordinate systems: These are recommended when you are 

interested in precise latitudes and longitudes. They are used in GPS, the most 

common is the SCR WGS84: EPSG:4326 

• Projected coordinate system: these are suitable when you want to know an area, 

a distance or something else. The most common is the UTM. 

It is sometimes necessary to convert a layer from one projection system to another. To 

know the SCR of the layer: right-click on the layer > Properties > Information > SCR.  

To reproject a layer, use the reproject tool which is available in: 

 Vectors > Data Management Tools > Reproject Layer… 

Activity: Reproject a vector layer 

✓ Open the reprojection vector layer tool and select wca_admbnda_adm0_ocha layer 

as the input layer, select Africa_Albers_Equal_Area_Conic (EPSG: 102022) projection 

as the target CRS, and then press “Run”. A new temporary layer, called Reprojected 

is added to the project 

✓ Verify the project of this new layer 
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4.13   Internet services 

4.13.1 Open Street Map data 

Open Street Map OSM is a free service of worldwide and up to date data regarding 

roads and building accessible throw the internet. To use OSM data it is necessary to 

install the QuickMapServices extension by going to the menu Plugins > Manage and 

Install Plugins, searching for the QuickMapServices plugin and installing it. 

The first use of OSM is to display a background map. For that, you will then be able to 

display OSM and other data directly from the menu  

Web > QuickMapServices > OSM > OSM Standard. 

A second use is to integrate OSM data as layers in the project: 

• On the display window, zoom on the area of interest 

• Open the menu Vector > QuickOSM > QuickOSM 

• On the QuickOSM menu, select Map preset, click on Urban,  

and select “Canvas Extent”, then click “Run preset” (Figure 18) 

• Check that new layers are added to the canvas 

 

 

 

 

 

 

 
 
 
 
 
 

Figure 18 – QuickOSM menu window 
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Figure 19 – Open Street Map data over Aberdeen Neighbourhood in Freetown 
 
 

4.13.2 Satellite imageries 

QGIS permits to display of satellite imageries accessible directly from the internet. For 

that, it is necessary to make a new connection with a satellite data service by clicking 

on the Browser panel to click right on XYZ Tiles > New connection (Figure 20). 

Then you are asked to give the connection a name and enter a URL. The most used 

URLs are: 

• Google Maps: https://mt1.google.com/vt/lyrs=r&x={x}&y={y}&z={z} 
• Google Satellite: 

http://www.google.cn/maps/vt?lyrs=s@189&gl=cn&x={x}&y={y}&z={z} 
• Google Satellite Hybrid: https://mt1.google.com/vt/lyrs=y&x={x}&y={y}&z={z} 
• Google Terrain: https://mt1.google.com/vt/lyrs=t&x={x}&y={y}&z={z} 
• Google Roads: https://mt1.google.com/vt/lyrs=h&x={x}&y={y}&z={z} 

While the new connection is established, you could add layers to the project by rick 

clicking on the XYZ Tiles service name and “Add Layer to Project”. A new raster layer 

will be added to the project. 
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Figure 20 – Example of adding Google Satellite connection to XYZ Tiles 

 

 

 

 

 

 

 

 

 

 

Figure 21 – Google Satellite Image over Aberdeen Neighbourhood in Freetown 
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4.14   Digitizing 

It could be useful to create a new vector layer and add features to it. For example, you 

may want to indicate on a map the precise location of schools, water points, hospitals, 

etc.  

To do this, start by creating an empty shapefile  

Layer > Create Layer > New Shapefile Layer. It is necessary to specify whether the 

vector layer will contain points, lines, or polygons and to give it a file name. Then it is 

possible to add the names of the various fields which will be present in the layer by 

specifying the name of the field and the type (string for characters, date for dates, 

number, integer, etc.). 

Once the shapefile is created, it is necessary to add data to the shapefile. To do this, 

click on the layer and then switch to edit mode using 

 

Then you can start adding data by doing two things: 

• Digitize the geometry (i.e., point, line, polygon) 

• Enter the attributes of the attribute table 

 

Useful tools can be found in the editing toolbar 

• To add a new feature: 

      for a new point,       for a new line and       for a new polygon 

• To move the entity: 

       To move a point,       to move a line,       to move a polygon 

• Entities could be removed by selecting it a pressing “suppr” key 

•        To save changes  

•        To exit the editing mode 

 

When adding a point, simply go to the area where you want to add it and left-click, and 

it will be added automatically. For lines and polygons, left-clicking adds segments while 

right-clicking stops adding segments and finishes the line and polygon.  
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Activity: Create a polygon vector file from a satellite image 

✓ Open New Shapefile Layer tool: Layer > Create Layer > New Shapefile Layer 

✓ Create a new empty vector layer of geometry type of polygons and name it 

crop_field.shp Layer, and add fields to this empty vector layer and give them names 

such as ID and Name 

✓ Using the google Satellite Layer, zoom on an agricultural area and start an editing 

session and add different rice field features based on satellite images or OSM 

✓ Complete the attribute table for these entities 

✓ Save the changes and exit editing mode 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 22 – Digitization of crop parcels in central Mali from Google Satellite imagery 

 



QGIS SOFTWARE USER GUIDE V1                                                                                  42 

ACTION CONTRE LA FAIM | ACTION AGAINST HUNGER | Regional Office for West and Central Africa 

www.actionagainsthunger.org | www.actioncontrelafaim.org | www.accioncontraelhambre.org 
www.sigsahel.info 

5 Raster data 

This section on raster data is introductory. Its purpose is simply to be able to display a 

raster and change its style. We have already seen earlier how to add a raster layer to 

the QGIS project. As a reminder, raster layers are often saved in GeoTIFF .tiff format. 

5.1 Symbology 

In this introduction, we focus only on the display of single-band raster images. This 

corresponds for example to biomass production and biomass production anomaly 

images. These images are characterised by a single band that stores for each pixel the 

value of the layer. For example, the band of a biomass production anomaly image stores 

for each pixel the value of the anomaly ranging from 0 to 200%.  

To adjust the style of a raster layer, right-click > Properties > Symbology It is then 

possible to select the type of rendering between: 

• Multiband color: To be used with a multiband image 

• Paletted/Unique values: To affect to each unique value a different colour 

• Singleband grey: to give a grey gradient to the layer 

• Singleband pseudocolor: To affect each range of values a different colour 

• Hillshade: To be used with elevation model to represent relief 

• Contours: To be used to represent limits in local variation, as for elevation level 

lines 

When we add a raster layer to QGIS, by default it will be the “singleband grey” but other 

colour display mode could be selected in the properties.  

For the biomass anomaly map, it is necessary to select “singleband pseudocolor” to set 

the limits between 0 and 200, to choose a discrete interpolation, a continuous 

classification mode with 10 classes so that each class includes a range of 20% of values. 

Then, it is necessary to add two additional values by clicking on them to put the values 

lower than -9998 in off-white and those of -9997 in grey. These values correspond to 

areas with no data because the biomass is absent. The style window should now look 

like Figure 23. 
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Activity: Produce a colour ramp the symbology for a raster layer 

✓ Edit the symbology of layer Anomaly_biomass_2021.tif and reproduce the 

colour gradient from red to green as shown in Figure 23 

✓ Clicking on        , permits to add specific colours for values -9998 and -9997 

which correspond to desert areas where the calculation of the anomaly was not 

possible 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 23 – Symbology used to display the biomass anomaly raster layer 
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Figure 24 – Annual biomass production anomaly for the year 2021  

over the central Sahel 

5.2 Pixel value tool 

A useful tool for finding out the value of each pixel can be installed. To do this, go to 

Plugins > Manage and Install Plugins, search for Value Tool and install it.  

Once the extension is installed, a new icon appears in the toolbar          . By clicking on 

it, a window appears, and you need to check Enable to activate the tool. After having 

selected a raster layer, such as BiomassAnomaly2021, while moving the mouse causes 

the corresponding pixel value is displayed in the Value Tool extension window. 

5.3 Area statistics 

The area statistics tool allows the calculation of statistics on raster layers based on areas 

of interest defined by polygons. Different statistical functions are available such as 

average, minimum, maximum, etc. To access this tool, open the Processing Toolbox in 

View > Panels > Processing Toolbox and search for the tool named  

Raster analysis > Zonal statistics 
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Figure 25 – Zonal statistics tool menu window 

Activity: Calculate the average biomass anomaly for the Tillabéry region of Niger 

✓ Open the area statistics tool and put the raster layer BiomassAnomaly2021 and 

the vector layer wca_admbnda_adm1_ocha 

✓ Choose the statistics to be calculated, including ‘Mean’ 

✓ Check the results stored in the attribute table of the new vector layer created 

named Zonal Statistics  

 

 

 

 

 

 

 

 

 

Figure 26 – Statistical values stored in the attribute table 
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5.4 Geo-referencing tool to assist digitisation 

Durant participatory mapping exercise, people draw freehand on a map, and 

information is therefore produced on paper. It is then necessary to digitise this 

information to create spatialised data to be used either as a decision support tool or to 

produce maps. 

To open the georeferencing tool, click on Raster > Georeferencer, and a window opens 

on which you can add the layer to be georeferenced using the icon         . It is also 

necessary to specify the reference coordinate system RCS for the layer (e.g., WGS84, 

EPSG: 4326). The image is then added to the window. Once the image has been added, 

ground control points GCP must be added to georeference the map. To do this, two 

possibilities exist 

• You know the coordinates of certain points visible on the map to be 

georeferenced. In this case, click on a place on the map for which you know the 

coordinates and enter the coordinates manually. 

• You do not know the exact coordinates, but you have opened in QGIS the 

administrative boundaries or villages that are present on the scanned map. You 

can then click on an easily locatable place and then select from the map canvas 

bouton                         and just select the place in the QGIS window that 

corresponds to the control point. 

You need to add several control points, at least a dozen, and spread them well over the 

map. Once this is done, click on      to start the georeferencing. You need to give a name 

to the raster layer and leave the other parameters by default (Thin plate spline, nearest 

neighbour, EPSG:4236 - WGS 84). Then, when you click ok, the georeferencing starts 

and the layer can be added and used to facilitate the digitisation. 

Activity: Georeferencing a scanned map on transhumance corridors over the region of 

Mayahi in Niger 

✓ In the canvas, display layer wca_admbnda_adm2_ocha and zoom on the 

department of Mayahi (region of Maradi) in Niger 

✓ Open the Georeferencer menu windows 

✓ Select the file Mayahi/Mayahi_Corridors.png to be georeferenced 

✓ Plot a point along the region boundary in red, click on   and 

select the same point on the canvas 

✓ Repeat the operation for a dozen a point along the whole region boundary 
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Figure 27 – Georeferencer window during the process  

of ground control point selection 

 

 

 

 

 

 

 

 

 

Figure 28 – Main QGIS window during the process of ground control point selection  

 

 



QGIS SOFTWARE USER GUIDE V1                                                                                  48 

ACTION CONTRE LA FAIM | ACTION AGAINST HUNGER | Regional Office for West and Central Africa 

www.actionagainsthunger.org | www.actioncontrelafaim.org | www.accioncontraelhambre.org 
www.sigsahel.info 

6 Page layout - print composer 

Having seen how to correctly process and display vector and raster data, it is now useful 

to create a map that can be exported to be used in other software or to be printed out.  

6.1 Creating a new Layout 

To do this, you need to create a new print composer Project > New Print Layout and 

give your layout a name and a new window, the layout composer, will open. This will 

allow you to create the map, set a scale, and add all elements requested to create the 

final map. If you want to open the saved layout, just go to Project > Layout and choose 

the corresponding layout.  

It is preferable to define the size of the card printout (A0, A2, A3, A4 or other) from the 

start so that it is directly produced in the correct format. To do this, select Item 

Properties on the right folder, and select one of the predefined sizes (e.g., A4) or specify 

manually the width and height in millimetres and the orientation of the layout. 

 

 

 

 

 

 

 

 

 

Figure 29 – Layout composer window  

Between all, two boutons are very useful:  

•  permits to set the zoom of canvas at its maximum to fill up the entire window 

• forces the refreshing of the viewer while changes have been made in the 

main QGIS window 
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6.2 Adding a map and changing the page size 

To add a map, the location of the map must be drawn using.  

To move around the map, use the icon  and hold the left button while moving the 

mouse. Map zoom could be adjusted using the mouse wheel and fine-tuned by keeping 

the shift key pressed.   

The map, as every object present on the layout, could be moved on the canvas by 

switching on , clicking on the map as a graphical object with maintaining the left 

mouse button pressed, and moving the mouse. The size of the graphical object could 

be adjusted by moving one of its corners. 

6.3 Adding the scale  

A map should always contain a scale. The graphical scale is generally preferred to the 

numerical scale because the latter is retained even if the final size of the map is changed. 

To add a scale, click on and draw the desired location for the scale. A property 

window of the object opens and refers to the scale bar. In this window, it is possible to 

manage all the parameters of the scale, i.e., units, segment width, writing size, colours… 

6.4 Adding the legend 

Any map that includes vector or raster layers representing features must be 

accompanied by a legend. To add a legend, select and draw the area where the 

legend is to be added. In the properties of the legend object, the "Auto Update" 

checkbox should be unchecked to be able to make changes to the names of the layers 

and to remove certain elements that are not relevant to the map. 

6.5 Addition of a North arrow 

It is often advisable to add a North indication. For this, click on  and add an arrow 

on the map. Other arrows are available in the SVG Group arrows. 

6.6 Adding an image or logo 

A card made by ACF must contain the ACF logo. To add it, proceed as before by adding 

an image using . Once the location has been drawn, the path to the image must be 

added in the object's property window. For better quality, it is preferable to use svg 

vectorial file format such as Data/Logo/Acf_Logo.svg 
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6.7 Adding a title 

To add text, click on then  in the object properties, it is possible to write the title, 

modify the typography and the size of the text. This text tool can also be used to specify 

the sources of the map data or for any other text addition.  

6.8 Adding graphical element 

Optional graphical elements, such as rectangle, line, circle, could be easily added to the 

canvas by clicking on . Filling colours, and outside borders could easily be adjusted 

by using the Item Properties menu. 

6.9 Exporting the map 

Once the map is finished, the final operation is to export it. This could be done in 

different formats: 

• By clicking on  to export as a pdf file easily shareable or printed out. 

• By clicking on  to export as a raster image (.png, .jpg, …) for easy handling to 

be inserted into to document, but with a slight loose of the quality. 

• By clicking on  to export as a vectorial image (.svg) for high-quality document 

but more complex to handle and with generally an increase of file size. 

 

 

 

 

 

 

 

 

 

 

Figure 30 – Example of map production  
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